全新的 Ubuntu 使用 apt 安装却出现错误

今天拿到了一台全新的 UbuntuServer,在上面使用之前的一键脚本安装依赖,却始终不能成功,一键脚本是专门为 Ubuntu 定制过,之前在其他的服务器上测试都是可以的,遇到这个问题有点懵逼,Google 无果之后 仔细看了报错信息,报错讲

No apport report written because MaxReports is reached already
Adding system user `mongodb' (UID 112) ...
Adding new user `mongodb' (UID 112) with group `nogroup' ...
useradd: cannot open /etc/group

于是发现是/etc/group 这个文件有问题,使用 lsattr /etc/group之后发现被加了一个 i 的标志位。于是使用chattr -i /etc/passwd去掉之,之后继续报错,使用chattr -i /etc/gshadow
去掉另外一个文件的标志位就可以了。
生活真是艰难啊。

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注

This site uses Akismet to reduce spam. Learn how your comment data is processed.